Intermittantly slow and unresponsiveness

Incident Report for 12Build

Resolved

This incident has been resolved.
Posted Jan 19, 2026 - 13:55 CET

Investigating

We are currently investigating the issue.
Posted Jan 19, 2026 - 13:40 CET
This incident affected: Marketplace.