Database issues
Incident Report for 12Build
Resolved
This incident has been resolved.
Posted Mar 04, 2024 - 15:15 CET
Investigating
Currently, we are getting many reports that downloading/uploading is not working and there are problems with the bill of quantities.
Posted Mar 04, 2024 - 11:45 CET
This incident affected: Matchmaker.