disruption incident

Incident Report for 12Build

Resolved

This incident has been resolved.
Posted May 07, 2026 - 18:53 CEST

Update

The issue seems to be resolved.
Posted May 07, 2026 - 13:01 CEST

Investigating

At the moment, we are experiencing a disruption in the platform, resulting in multiple issues. Document downloads are not working, sending messages to subcontractors is not possible, and uploading documents is also affected, among other problems.
Posted May 07, 2026 - 11:31 CEST
This incident affected: Marketplace.