Problems with signing of nda documents through Validsign
Incident Report for 12Build
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 12:07 CEST
Identified
The issue has been escalated to our signing partner Validsign.
Posted Jul 11, 2022 - 11:04 CEST
This incident affected: Matchmaker.