Responsiveness 12Build MarketPlace and error: Ooops, something went wrong

Incident Report for 12Build

Resolved

This incident has been resolved. If you notice similar behaviour, please contact us via the 12Build chat or support@12build.com
Posted Jan 19, 2026 - 16:28 CET

Investigating

We are currently investigating the issue
Posted Jan 19, 2026 - 15:22 CET
This incident affected: Marketplace.